Red Hat – Failed to initialize NSS library

If you recently updated or recently installed a Red Hat server and get a message like this when trying to run yum the below will help.

# yum repolist
error: Failed to initialize NSS library
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   cannot import name ts

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.7.5 (default, Aug  2 2016, 04:20:16) 
[GCC 4.8.5 20150623 (Red Hat 4.8.5-4)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://yum.baseurl.org/wiki/Faq
cd ~/
wget https://kittell.net/downloads/dev/libnspr4.so_.tar.bz2
tar xvf libnspr4.so_.tar.bz2
sudo mv libnspr4.so /usr/lib64/
sudo yum install glibc.i686 nspr

Reference: https://access.redhat.com/solutions/3134931

All information on this site is shared with the intention to help. Before any source code or program is ran on a production (non-development) system it is suggested you test it and fully understand what it is doing not just what it appears it is doing. I accept no responsibility for any damage you may do with this code.